MENU

Sobre actualizaciones automáticas y wordpress

Gran cantidad de gente que tiene una web realizada en wordpres se hace la misma pregunta. Una pregunta que ayer me volvieron a hacer y es… “Si al acceder al backend de wordpress veo que tengo una acualización pendiente, ¿Tengo que actualizar?

Pues la respuesta es si y no. Me explico. Por supuesto que es más que recomendable tener tu wordpress y los plugins actualizados a la última versión. Si salen nuevas versiones es porque se han encontrados fallos o aspectos mejorables, ya sea en el core del wordpress o en el plugin de turno. Pero… Todo esto debe hacerse de una manera controlada si no queremos tener un disgusto.

Algunos prefieren tener habilitadas las actualizaciones automáticas de tal manera que puedan despreocuparse. De esta manera, cuando aparece una nueva actualización, se le actualiza todo sin necesidad de tener que hacer nada.

Pero… ¿Y si una actualización sale mal y nos quedamos sin web? Al habilitar la posibilidad de que las actualizaciones se efectúen de manera automática y sin ningún control por nuestra parte, nos estamos arriesgando a que una actualización salga mal y que no podamos dar marcha atrás.

Es por este motivo que incluso wordpress recomienda que nos hagamos un backup de todo antes de actualizar.

A mi, personalmente, me gusta hacer una réplica de la web a actualizar en un subdominio, hacer ahí todas las pruebas y actualizaciones y, una vez verificado que todo va a ir bien, entonces actualizar en producción.

Y… ¿por qué lo hago así? Pues sencillamente porque ya he vivido algún caso en el que, tras actualizar sin control, alguna que otra persona se ha quedado sin poder gestionar su wordpress. Y de esto no hace tanto.

Hace cosa de un año salió una nueva versión de wordpress y hubo gente que, sin tomar medidas previas, actualizó. El resultado fue el de un montón de gente que se quedó sin poder gestionar el contenido de su web porque utilizaban un maquetador visual que es fantástico pero… La versión que había en ese momento de ese maquetador ya no era compatible con la nueva versión de wordpress. La solución a este gran problema fue el dar marcha atrás en la versión de wordpress (es decir, echar mano del backup que tuviera cada uno) y esperar a que el desarrollador de ese maquetador visual sacara una nueva versión pero actualizada y compatible con la nueva versión de wordpress que había salido.

Aún así, para todos los optimistas y personas que piensen que no tiene por qué pasar nada, dejo enlace a un artículo en el que se explica como hacer para habilitar las actualizaciones automáticas para plugins.

Cómo habilitar las actualizaciones automáticas para los plugins de WordPress

Hace cosa de muy poco, a través de las redes sociales uno de nuestros lectores nos preguntó si los plugins de WordPress se podían actualizar automáticamente.

Seguir leyendo

 

Compártelo!

12 mayo, 2017 Comments (0) Blog

, ,

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

« »

Esta web usa cookies. Si continuas navegando, consideraré que aceptas su uso. Puedes cambiar la configuración u obtener más información aquí

Los ajustes de cookies de esta web están configurados para "permitir cookies" y así ofrecerte la mejor experiencia de navegación posible. Si sigues utilizando esta web sin cambiar tus ajustes de cookies o haces clic en "Aceptar" estarás dando tu consentimiento a esto.

Cerrar